Eclipse 설치-실행시 레거시 Java SE 6 런타임을 설치하지 말자

지금까지는 Qt Creator를 사용하다가, Eclipse를 설치해보려고 했더니 황당시구리한 팝업메시지를 볼 수 있었다.

문제점

  • Eclipse 설치를 할 때 Java Runtime Environment 최신 버전이 설치되어 있어도 위와 같은 메시지가 뜬다.
  • macOS 업데이트를 한 경우 라이브러리가 작살이 나는 경우가 있으므로 동일한 행동을 요구할 수 있다.
  • Java를 사용하는 다른 어플리케이션에서도 동일한 에러가 발생할 수 있다.

해결책

JRE가 아닌 JDK로 깔면 정상적으로 실행된다.

해당 경고 메시지의 추가 정보…의 내용을 확인하면 Java SE 6을 설치할 수 있는 다운로드가 있으나, 10년전에 지원이 끝난 버전 6를 설치하는 것은 권장하지 않는다.

답글 남기기